【Linux】【emacs】Emacs のセットアップ【SW】

Emacs のセットアップ
 
Ubuntu 17.04、および 18.04 環境で Emacs 25.1.1 かつ GUI版を想定した設定である。
emacs -nw でも動作するように Anything.el 等々のキーバインドにしているが、GUI版のようにすべて動作するかは不明。
Windows 環境での使用は想定していない。
一度設定をしたら、GitHub 等に丸ごとバックアップを取っておき、今後はそれをコピーして使うのようにする。
とてもでは無いが、一から構築する気力は起きない..
 

Emacs のセットアップ

 

1. Emacs のインストール

% sudo apt-get install -y emacs

 

2. auto-install の導入

% mkdir -p  $HOME/.emacs.d/auto-install
% cd $HOME/.emacs.d/auto-install
% curl -L -O https://www.emacswiki.org/emacs/download/auto-install.el
% emacs --batch -Q -f batch-byte-compile auto-install.el
In auto-install-mode:
auto-install.el:933:9:Warning: ‘font-lock-fontify-buffer’ is for interactive
    use only; use ‘font-lock-ensure’ or ‘font-lock-flush’ instead.
‘dont-compile’ is an obsolete macro (as of 24.4).

 
auto-install.elc が生成されていれば OK。

% ls -ltr
-rw-r--r-- 1 neko neko 58839  513 00:17 auto-install.el
-rw-r--r-- 1 neko neko 30636  513 00:18 auto-install.elc

 
$HOME/.emacs を作成し、auto-install を使うための設定を記述する

(require 'package)
(add-to-list 'package-archives '("melpa" . "http://melpa.milkbox.net/packages/"))
(add-to-list 'package-archives '("marmalade" . "http://marmalade-repo.org/packages/"))
(fset 'package-desc-vers 'package--ac-desc-version)
(package-initialize)

(add-to-list 'load-path (expand-file-name "~/.emacs.d/auto-install/"))
(require 'auto-install)
(auto-install-update-emacswiki-package-name t)
(auto-install-compatibility-setup)

 

3. emacs を起動させて、以下を使い分けてインストールする

  • M-x auto-install-batch
  • M-x auto-install-from-emacswiki
  • M-x list-packages

使い分けについては、Emacsテクニックバイブル ?作業効率をカイゼンする200の技? にて次のように記述されている。

ELPA で提供されているものは ELPA を、そうでないものは auto-install.el を使いましょう。両者は補完し合っています。

 

4. $HOME/.emacs の更新が行われる

上記 3 により ELPA でインストールしたパッケージをロードする記述が追加されるので、該当パッケージはこの記述以降に固有の設定を書く。

(custom-set-variables
 ;; custom-set-variables was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 '(package-selected-packages (quote (auto-install))))
(custom-set-faces
 ;; custom-set-faces was added by Custom.
 ;; If you edit it by hand, you could mess it up, so be careful.
 ;; Your init file should contain only one such instance.
 ;; If there is more than one, they won't work right.
 )